| Mobile | RSS

OS X on Dell D420

December 16th, 2009 | 12 Comments | Posted in apple, gnu/linux, hardware, software, ubuntu

After running Ubuntu Karmic Koala for about a month on the my Dell D420, I have decided to give OS X a try.

I started here.

Ended up here.

10.5 was a bust.
10.6 works great!

The process I used was:

1. Get 10.6 disc or disc image.
2. Make an external hard drive version of it.
3. Boot from the D620SLV1 disc from the second thread.
4. Choose to boot from the USB hard drive (now an install disk) and then install from it.
5. Woo!

Since my Intel 3945 card wasn’t supported out of the box, I switched my Broadcom card from my Dell Mini 9 (now happily running Ubuntu for my daughter) so I could have working wireless. It required I run the Broadcom script found here, which adds the ID of the Dell Mini Broadcom card.

I also ordered a Dell 1490 card, which has not come yet, but I have read that this kext editing is not necessary with that card, as it is recognized as is. We’ll see.

Other than that, seems like everything I care about is working, except the SD card.

Anyone have that working on their D420?

Follow Discussion

12 Responses to “OS X on Dell D420”

  1. Ayaz Says:

    Hi. I’m glad to hear that you had some good success with the installation method. I too have gotten as far as installing a working version by using Leppy’s guide, though I instralled from my D-bay drive. However, I have not had any luck in running the post-installer. I can’t seem to find the optical drive listed anywhere! It certainly exists in the System Profiler and Disk Utilities and I can eject it using the Eject icon on the top menu bar, but I can’t seem to read any disks! How did you get the Post-Installer installed? Thanks for your help. Regards Ayaz.

  2. r.jimi Says:

    @Ayaz –

    I didn’t have your issue because I installed from USB. It seemed to work fine running the post-install from the external drive.

    You should put the contents of the Snow Leopard boot disc on a USB stick and then install from there.

    As for your issue with the D-Bay drive, I’m not sure. Perhaps the drive is CD-ROM only and you have a DVD? I got my D420 as a refurb, so no accessories for it.

    Hope this helps you!

  3. Ayaz Says:

    Hi. Thanks for your prompt reply – it’s much appreciated. I decided to mount the post-installer via a network drive, which worked perfectly. I’m really pleased to notice that the audio control and, in particular, headphone jack mute is working. Do you recommend any other post-install apps / kexts, eg. the Voovo audio kext? I’m about to tackle the sleep / standby issue – do you have any suggestions? Let’s keep in touch. Regards Ayaz.

  4. r.jimi Says:

    I went down the Voodoo kexts road, but never got satisfaction. Unrelated to that, I ended up having to do a completely reinstall and have just left it where it was, in terms of what was working after the post-installer. I tried the main tips on getting sleep to work (something with Wake-on-USB/Legacy USB in bios, I don’t remember off the top of my head), but I never got it working.

    The thing that I would take over standby though, is getting the SD slot working. Using the kexts that are out there, I was able to get the D420 to recognize it, but nothing more. Basically, I still have a “stock” Snow Leopard install, except for the post-installer.

  5. Ayaz Says:

    Well, I tried to get a triple boot working from an Acronis backup of XP and Vista (don’t know why I want Vista anyway), so that I coluld get online with my WWAN card (Option Icon 7.2) but I ran into lots of problems with the boot loader / partition ID etc, so I’m back at the stock install and I’m going to opt for a Dell 5530 WWAN card instead.
    I agree with you about the SD card though, boot up and shut down speed is so quick that, like you, I could get by without standby.
    I had some bad news though – I bought a HS122JC 5400rpm ZIF drive, which definitely speeded up the system overall, but Ileft it on the train!!!!
    Even if I don’t get it back soon, I will definitely get another one, becuase they are fast, fast, fast!
    Thanks for your help – I’ll keep you posted.

  6. Andreas Says:

    Hi!
    How did you make the osx bootable harddrive?

    I am really struggling!

    Regs

    Andy

  7. Andy Says:

    Hi Andy. I have some good news regarding the SD card reader. Check out the instructions at the following site – http://www.dailyblogged.com/449/sd-card-reader-working-on-hackbooks/ – they worked for me using an 8gb micro SD and adapter, though I haven’t tested any others yet. I’m not sure I understand your question about making “the osx bootable harddrive”. However, what I’ve done so far is use Leppy’s method. ie. I used the D620SLV1 cd and a full retail DVD of Snow Leopard to make a clean install of OsX on the hard disk, which has partition 1 for OsX (Journaled) and partition 2 for Ubuntu (Fat). After completing the install of OsX, I rebooted the system with the D620SLV1 CD and selected the hard disk. After OsX booted up, I ran Post_Install.command from the CD and followed the instructions for installing Chameleon (option 1) for Intel GMA (option 1 again). The next time I rebooted, I was able to boot from the hard disk directly. I’ve not had any success with XP yet, but Ubuntu works and dual boots with a little modification to GRUB. I hope this helps. Let me know if you get the SD working for yourself. Regards Ayaz.

  8. Ayaz Says:

    Hi Andy. I’m finally triple booting with XP, OsX and Ubuntu, but what a palaver!! I bought myself another 120gb HS122JC drive – fingers crossed that South Eastern will find my other one. If you want a full guide on what I did, I can share it with you to try out first, or I’ll post it as a guide on InsanelyMac etc. Happy to talk you through if you want. A.

  9. lutin Says:

    Removed NullCPUPowermangement and SleepEnabler – rebuilt kext cache and installed 10.6.3 with no fuzz

  10. r.jimi Says:

    Hey Lutin!

    I finally tried to update based on your comments. Thanks! I didn’t have either of those so kexts so I was fine just updating. Are you posting in the thread on insanleymac too? I hate trying to read through that thing!

    If everyone who has posted here is on the same Retail install, I can create a page for OS X on D420 to list the know working configs and kexts for each version. I don’t have too much time to go find them, but if you post your config I will compile them.

  11. rol Says:

    have installed OS X as above and have upgraded to 10.6.3 – all runs fine (have the Broadcomm WiFi card) _except_ SLEEP: a huge number of posts around this with (for me) inconclusive results:
    Qestion: has anyone installed OSX on the D420 with the above method and actually has Sleep (and wake-up 😉 working? If do what/how did you do it ?

  12. Andrew M Says:

    I have been running Snow leopard on D420 for about 4 months now. 10.6.3 works fine. 10.6.4 killed the broadcom wifi chip (4311), I reverted back to 10.6.3. I believe there is a fix for broadcom/10.6.4 now, but haven’t tried it.
    Sleep does not work on this machine (sleeps actually works, but it won’t wake). Some people had success with sleep on D620, by enabling system password in BIOS, but this trick does not work for D420.

    I also was able to install the OSX on an external USB drive and booting it from external USB.

Leave a Reply

Time limit is exhausted. Please reload the CAPTCHA.